<!DOCTYPE html>
<html lang="en">
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />    <meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1">
    <link href="/favicon.ico" type="image/x-icon" rel="icon"/><link href="/favicon.ico" type="image/x-icon" rel="shortcut icon"/>	<title>Congressman Price's Statement on the Passing of Betty McCain - Durham, NC</title>
	<meta name="page_title" content="Congressman Price&#039;s Statement on the Passing of Betty McCain - Durham, NC"/>
	<meta name="robots" content="index, follow"/>
	<meta content="Congressman Price&#039;s Statement on the Passing of Betty McCain - Durham, NC" name="description"/>
	<meta content="Congressman, Price, s, Statement, on, Passing, of, Betty, McCain, Durham, NC" name="keywords"/>
	<link rel="canonical" href="https://www.americantowns.com/news/congressman-prices-statement-on-the-passing-of-betty-mccain-31495818-durham-nc.html" />
	<meta name="twitter:card" content="name"/>
	<meta property="og:url" content="http://www.americantowns.com/news/congressman-prices-statement-on-the-passing-of-betty-mccain-31495818-durham-nc.html"/>
		<meta name="facebook-domain-verification" content="uaqqzwet8z363epby73w309yhqd86f" />
	
	<link href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/css/bootstrap.min.css" rel="stylesheet">
	<link href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/css/bootstrap-theme.min.css">

	<link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.4.0/css/font-awesome.min.css" rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'">
	<link href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,400,300,600,700' type='text/css' rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'">
	<link href="https://p300live-americantownscom.netdna-ssl.com/css/animate.min.css" rel="stylesheet">

	<link href="https://p300live-americantownscom.netdna-ssl.com/css/style.min.css?v=1.09a" rel="stylesheet">
	<link href="https://p300live-americantownscom.netdna-ssl.com/css/americantowns.min.css?v=1.09a" rel="stylesheet">

	<noscript>
		<link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.4.0/css/font-awesome.min.css" rel="stylesheet">
		<link href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,400,300,600,700' type='text/css' rel='stylesheet'>
		<link href="https://p300live-americantownscom.netdna-ssl.com/css/animate.min.css" rel="stylesheet">
	</noscript>

		<style type="text/css">
	.adname {font-size:10px; text-align:center;}

	</style>
	
	<script src="https://code.jquery.com/jquery-3.2.1.min.js" integrity="sha256-hwg4gsxgFZhOsEEamdOYGBf13FyQuiTwlAQgxVSNgt4=" crossorigin="anonymous"></script>
	<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-2972288465131749"
     crossorigin="anonymous"></script>

   <!--  Media.net Async -->
<script type="text/javascript">
    window._mNHandle = window._mNHandle || {};
    window._mNHandle.queue = window._mNHandle.queue || [];
    medianet_versionId = "3121199";
            </script>
<script src="https://contextual.media.net/dmedianet.js?cid=8CU8L15W1" async="async"></script>


<!-- <script type='text/javascript' src='https://pixel.driveniq.com/vpixel.js?ver=1.1.0'></script> -->
 


<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '1662663580647713');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1662663580647713&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<meta name="facebook-domain-verification" content="uaqqzwet8z363epby73w309yhqd86f" />

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-370662-1', 'americantowns.com');
  ga('send', 'pageview');
var dimensionValue = '1';
ga('set', 'dimension1', 'Durham, NC');
</script>


<!-- START OF Onclick Google Analytics TAG -->
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-45868632-1']);
  _gaq.push(['_trackPageview']);
 _gaq.push(['_trackPageLoadTime']);
ga('1', 'Durham, NC', 'Town');
  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();


function _pageTracker (type) {
this.type = type;
this._trackEvent = function(a,b,c) {
_gaq.push(['_trackEvent', a, b, c]);
};
this._trackPageview = function(a) {
_gaq.push(['_trackPageview', a]);
};
}
var pageTracker = new _pageTracker();

</script>
<!-- END OF Onclick Google Analytics Tag -->

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>


<script type="text/javascript">
 var p = /yp\/.*escort/g;
 var Restricted = p.test(window.location.href);
</script>

<!-- <script type='text/javascript'>
if (!Restricted) {
googletag.cmd.push(function() {
googletag.defineSlot('/1005417/AmericanTowns_728_Top_Interior', [728, 90], 'div-gpt-ad-1365456931459-2').addService(googletag.pubads());
googletag.defineSlot('/1005417/AmericanTowns_728_Top_Interior_Left', [728, 90], 'div-gpt-ad-1367007795783-0').addService(googletag.pubads());
googletag.defineSlot('/1005417/AmericanTowns_300_Top_Side', [300, 250], 'div-gpt-ad-1365456931459-0').addService(googletag.pubads());
googletag.defineSlot('/1005417/AmericanTowns_728_Bottom_Interior', [728, 90], 'div-gpt-ad-1365456931459-1').addService(googletag.pubads());

googletag.pubads().setTargeting('State', 'NC');
googletag.pubads().setTargeting('County', 'Durham County');
googletag.pubads().setTargeting('City', 'Durham');

googletag.enableServices();
});
}
</script>
<script language="JavaScript">
/*GA_googleAddAttr("State", "NC");
GA_googleAddAttr("County", "Durham County");
GA_googleAddAttr("City", "Durham");*/
</script> -->

<script>
  window.teads_analytics = window.teads_analytics || {};
  window.teads_analytics.analytics_tag_id = "PUB_23807";
  window.teads_analytics.share = window.teads_analytics.share || function() {
    ;(window.teads_analytics.shared_data = window.teads_analytics.shared_data || []).push(arguments)
  };
</script>
<script async src="https://a.teads.tv/analytics/tag.js"></script>


    <script>
		var currentTownUrl = 'durham-nc';
		var basecdn = 'https://p300live-americantownscom.netdna-ssl.com';
			</script>
	<script type="text/javascript" async src="//forms.americantowns.com/js/formsApi.js"></script> 
	<script type="text/javascript" async src="//forms.americantowns.com/js/jspopupscript.js"></script>  
	<link rel="stylesheet" href="//forms.americantowns.com/css/jspopupstyle.css">
	</head>
<body>

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=136197816738139";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<div id="wrapper" class="single-page">
	<header id="header" data-domain="forms.americantowns.com">
		<!-- DrivenIQ Pixel --> 
<script>vpixel.piximage('9122');</script>


<div class="container header-banner">
<div class="col-sm-6 location">
<div class="media">
<div class="media-left media-middle atn-logo ">
<a href="/reset-town/"><img class="media-object" src="//imgcdn-americantownscom.netdna-ssl.com/img/at-logo.png" width="65" height="68" alt="american towns"></a>
</div>
<div class="media-body">
<h1 class="media-heading"><a href="/durham-nc/">Durham</a></h1>
<h3>North Carolina <button type="button" class="btn btn-primary btn-xs" data-toggle="modal" data-target="#chgn-city">Nearby Towns</button></h3>
<div class="modal fade chgn-city" id="chgn-city" tabindex="-1" role="dialog" aria-labelledby="basicModal" aria-hidden="true">
	<div class="modal-dialog">
		<div class="modal-content">
			<div class="modal-header" id="changecityheader">
				<button type="button" class="modalCloseImg close" data-dismiss="modal" aria-hidden="true">X</button>
				<div class="modal-title">See Nearby Cities</div>
			</div>
			<div class="modal-body">
				<div id="changecity">
					<div id="city-list" data-count="0">
											<div class="row">
							<div class="col-sm-5">
								<ul>
																	<li><a href="/durham-nc/">Durham</a></li>
																	<li><a href="/tarawa-terrace-nc/">Tarawa Terrace</a></li>
																	<li><a href="/research-triangle-park-nc/">Research Triangle Park</a></li>
																	<li><a href="/chapel-hill-nc/">Chapel Hill</a></li>
																	<li><a href="/morrisville-nc/">Morrisville</a></li>
																	<li><a href="/carrboro-nc/">Carrboro</a></li>
																	<li><a href="/hillsborough-nc/">Hillsborough</a></li>
																	<li><a href="/bahama-nc/">Bahama</a></li>
																	<li><a href="/butner-nc/">Butner</a></li>
																</ul>
							</div>
							<div class="col-sm-7">
								<ul>
																	<li><a href="/cary-nc/">Cary</a></li>
																	<li><a href="/creedmoor-nc/">Creedmoor</a></li>
																	<li><a href="/efland-nc/">Efland</a></li>
																	<li><a href="/rougemont-nc/">Rougemont</a></li>
																	<li><a href="/apex-nc/">Apex</a></li>
																	<li><a href="/stem-nc/">Stem</a></li>
																
									<li><a href="/nc/">All North Carolina Cities</a></li>
									<li><a href="/reset-town/">Explore Another City</a></li>
								</ul>
							</div>
						</div>
										</div>						
					
				</div>
			</div>
			<div class="modal-footer">
				 <div id="city-list-search">
					<form id="form1" action="#" class="form-inline" method="get" name="form1">
						<div><label for="choose_city">Don't see the city you're looking for?</label></div>
						<input value="true" name="setts" type="hidden">
						<div class="form-group">
							<input id="choose_city" name="search_terms" class="form-control city-state" placeholder="City and State, or ZIP Code" type="text">
						</div>
						<button id="changecitybutton" type="button" class="submit btn btn-primary" alt="Submit button">Search</button>
						<button type="button" class="go-to-browser-location btn btn-primary" alt="Submit button" title="Use Browser/Current Location"><i class="fa fa-location-arrow"></i></button>
					</form>
				</div>	
			</div>
		</div>
	</div>
</div>



</div>
</div>
</div>
<div class="col-sm-6 hidden-xs">
<div class="login">
<div class="americantowns-full-logo sprite hide-text"><a href="/reset-town/">AmericanTowns.com</a></div>
<ul id="user-nav" class="list-inline text-right">
<li class="b login"><a class="formsapi-login" onclick="return false" href="/login" id="ajaxMLogin">Log In</a></li>
<li class="b register"><a class="formsapi-register" onclick="return false" href="/register">Register</a></li>
<li class="b logout"><a class=" log-out-cookie" href="/logout" onclick="return false">Log Out</a></li>
<li class="b my-profile"><a class="openMyprofileInApi" onclick="return false" href="/myprofile">My Profile</a></li>
<li><a href="http://support.americantowns.com/home" target="_blank">Help</a></li>
<li><a class="rss-link sprite icon" href="/durham-nc/rss"><span class="hidden">Subscribe to our RSS</span></a></li>
<li><a target="_blank" class="twitter-link sprite icon" href="https://twitter.com/AmericanTowns"><span class="hidden">Follow us on twitter</span></a></li>
<li><a target="_blank" class="facebook-link sprite icon" href="https://www.facebook.com/bestofamericantowns/"><span class="hidden">Follow us on Facebook</span></a></li>
<li class="no-pad"><a target="_blank" class="mail-link sprite" href="http://support.americantowns.com/anonymous_requests/new">Email us</a></li>
</ul>	
</div>

</div>
</div>
<div class="header-menu autoresize">
	<nav class="atn navbar navbar-default">
		<div class="container container-fluid"> 
			<!-- Brand and toggle get grouped for better mobile display -->
			<div class="navbar-header">
				<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1" aria-expanded="false"> <span class="sr-only">Toggle navigation</span> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </button>
				<a class="navbar-brand" href="#">MENU</a>
			</div>

			<!-- Collect the nav links, forms, and other content for toggling -->
			<div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1">
				<ul class="nav navbar-nav">
					<li class="dropdown navbar-item"><a class="navbar-link home" href="/durham-nc/" title="Home"><i class="glyphicon glyphicon-home"></i></a></li>

<li class="dropdown navbar-item"> <a class="navbar-link" role="button" aria-haspopup="true" aria-expanded="false">Local Guides</a>
						<ul class="dropdown-menu">


<li><a href="https://todayslocaldeals.com/durham-nc/" title="Deals & Coupons">Deals & Coupons</a></li>		
<li><a href="https://communityanswerbook.com/durham-nc/" title="Community Answer Book">Community Answer Book</a></li>			
<li><a href="https://coronavirusresourceguide.com/durham-nc/" title="Coronavirus Resource Guide">Coronavirus Resource Guide</a></li>							
<li><a href="/durham-nc/prepping-guide/" title="Prepper's Guide">Prepper's Guide</a></li>
<li><a href="/durham-nc/voting-guide-polling-place-locations/" title="2022 Election Guide">2022 Election Guide</a></li>
							
													</ul>
					</li>

					<li class="dropdown navbar-item"><a class="navbar-link" href="/durham-nc/things-to-do/" role="button" aria-haspopup="true" aria-expanded="false">Entertainment</a>
						<ul class="dropdown-menu">
                                                        

							<li><a href="/durham-nc/things-to-do/" title="Things To Do">Things To Do</a></li>
                                                        <li><a href="/durham-nc/local-food/" title="Farmers' Markets">Farmers' Markets</a></li>
                                                        <li><a href="/durham-nc/movie-times/" title="Movie Times">Movie Times</a></li>
							<li><a href="/durham-nc/events-this-weekend/" title="Events this Weekend">Events this Weekend</a></li>
							<li><a href="/durham-nc/events/" title="All Events">All Events</a></li>
<!--                                               	<li><a href="/durham-nc/memorial-day-parades-2022/" title="Memorial Day Parades">Memorial Day Parades</a></li> -->
                                                        <li><a href="/durham-nc/4th-of-july-2022-fireworks-parades/" title="July 4th Fireworks">July 4th Fireworks</a></li>
                                                        <li><a href="/durham-nc/apple-picking-and-apple-farms/" title="Apple Picking">Apple Picking</a></li>
                                                        <li><a href="/durham-nc/corn-mazes/" title="Corn Mazes">Corn Mazes</a></li>
                                                        <li><a href="/durham-nc/pumpkin-patch-farms-and-pumpkin-picking" title="Pumpkin Picking">Pumpkin Picking</a></li>
                                                        <li><a href="/durham-nc/trick-or-treat-halloween-events-haunted-houses/" title="Halloween events">Halloween Events</a></li>
                                                         <li><a href="/durham-nc/veterans-day-parades-events/" title="Veterans Day Parades">Veterans Day Parades</a></li>
                                                        <li><a href="/durham-nc/ice-skating-rinks/" title="Ice Skating Rinks">Ice Skating Rinks</a></li>
                                                        <li><a href="/durham-nc/ski-resorts/" title="Ski Resorts & Mountains">Ski & Snowboard Resorts</a></li>
                                                        <li><a href="/durham-nc/cut-your-own-christmas-tree/" title="Christmas Tree Farms">Christmas Tree Farms</a></li>
                                                        <li><a href="/durham-nc/holiday-events-and-festivals/" title="Christmas and New Year's Events">Christmas and New Year's Events</a></li>
						</ul>
					</li>
					<li class="dropdown navbar-item"> <a class="navbar-link" href="/durham-nc/restaurants/" role="button" aria-haspopup="true" aria-expanded="false">Restaurants</a>
						<ul class="dropdown-menu">
							<li><a href="/durham-nc/restaurants/" title="Restaurants">Restaurants</a></li>
							<!--<li><a href="/durham-nc/restaurant-coupons/" title="Restaurant Coupons">Restaurant Coupons</a></li>-->
													</ul>
					</li>
					<li class="dropdown navbar-item"> <a class="navbar-link" href="/durham-nc/businesses/" role="button" aria-haspopup="true" aria-expanded="false">Directory</a>
						<ul class="dropdown-menu">
							<li><a href="/durham-nc/businesses/" title="Directory">Directory</a></li>
							<li><a href="https://bestlocalcardeals.com/durham-nc/" title="Car Deals">Car Deals and Guide</a></li>
							<li><a href="/durham-nc/yp/accountants/" title="Accountants">Accountants</a></li>
							<li><a href="/durham-nc/yp/physicians-and-surgeons/" title="Doctors">Doctors</a></li>
							<li><a href="/durham-nc/yp/dentists/" title="Dentists">Dentists</a></li>
							<li><a href="/durham-nc/yp/florists/" title="Florists">Florists</a></li>
							<li><a href="/durham-nc/yp/moving-storage/" title="Moving / Storage">Moving / Storage</a></li>
							<li><a href="/durham-nc/yp/plumbers/" title="Plumbers">Plumbers</a></li>
							<li><a href="/durham-nc/directory/" title="White Pages">White Pages</a></li>
							<li><a href="/durham-nc/zip-code/" title="Zip Codes">Zip Codes</a></li>
							<li><a href="/durham-nc/tv-stations/" title="TV Stations">TV Stations</a></li>
						</ul>
					</li>
					<!-- <li class="dropdown navbar-item"> <a class="navbar-link" href="/durham-nc/maps/" role="button" aria-haspopup="true" aria-expanded="false">Travel &amp; Transit</a>
						<!-- <ul class="dropdown-menu"> -->
							<!--<li><a href="/durham-nc/travel-transit/" title="Travel &amp; Transit">Travel &amp; Transit</a></li>-->
							<!--<li><a href="/durham-nc/travel-transit/" title="Car Rental">Car Rental</a></li>-->
							<!--<li><a href="/durham-nc/travel-transit/" title="Flights">Flights</a></li>-->
							<!--<li><a href="/durham-nc/travel-transit/" title="Hotels">Hotels</a></li>-->
							
							
							<!--<li><a href="/durham-nc/weather/" title="Weather">Weather</a></li>-->
							<!--<li><a href="/durham-nc/wifi/" title="WiFi">WiFi</a></li>-->
						<!-- </ul> -->
					<!-- </li> -->
					<li class="dropdown navbar-item"> <a class="navbar-link" href="/durham-nc/info/" role="button" aria-haspopup="true" aria-expanded="false">Community Life</a>
						<ul class="dropdown-menu">

<li><a href="https://coronavirusresourceguide.com/durham-nc/" title="Coronavirus Resource Guide">Coronavirus Resource Guide</a></li>							
<li><a href="/durham-nc/prepping-guide/" title="Prepper's Guide">Prepper's Guide</a></li>
							
<li><a href="/durham-nc/events/" title="Events Calendar">Events Calendar</a></li>
							<li><a href="/durham-nc/info/" title="Government">Community Profile</a></li>
							<li><a href="/durham-nc/organizations/government-and-politics/" title="Government">Government</a></li>
							<li><a href="/durham-nc/organizations/religion-and-spirituality/" title="Houses of Worship">Houses of Worship</a></li>
							<li><a href="/durham-nc/organizations/clubs-and-organizations/" title="Clubs and Non-Profits">Clubs and Non-Profits</a></li>
                                                        <li><a href="/durham-nc/volunteer-organizations/" title="Volunteer Organizations">Volunteer Organizations</a></li>
							<li><a href="/durham-nc/school-closings/" title="School Delays and Closings">School Delays and Closings</a></li>
							<li><a href="/durham-nc/organizations/schools-and-libraries/" title="Schools, Libraries">Schools, Libraries</a></li>
							<li><a href="/durham-nc/obituaries/" title="Obituaries">Obituaries</a></li>
							<li><a href="/durham-nc/organizations/" title="All Organizations">All Organizations</a></li> 
							<li><a href="/durham-nc/local-businesses/" title="All Organizations">Local Businesses</a></li> 
                                                        <li><a href="/durham-nc/maps/" title="Maps">Maps</a></li>
                                                        <li><a href="/durham-nc/gas-prices/" title="Gas Prices">Gas Prices</a></li>
                                                        <li><a href="/durham-nc/traffic-trains/" title="Traffic / Trains">Traffic / Trains</a></li>

						</ul>
					</li>
					<li class="dropdown navbar-item"> <a class="navbar-link" href="/durham-nc/classifieds/" role="button" aria-haspopup="true" aria-expanded="false">Classifieds / Jobs</a>
						<ul class="dropdown-menu">
							<li><a href="/durham-nc/classifieds/" title="Classifieds">Classifieds</a></li>
							<li><a href="/durham-nc/jobs/" title="Jobs">Jobs</a></li>
							<!--<li><a href="/durham-nc/coupons/" title="Coupons">Coupons</a></li>-->
							<!--<li><a href="/durham-nc/restaurant-coupons/" title="Restaurant Coupons">Restaurant Coupons</a></li>-->
						</ul>
					</li>
					<li class="dropdown navbar-item"> <a class="navbar-link" href="/durham-nc/news/" role="button" aria-haspopup="true" aria-expanded="false">News</a>
						<ul class="dropdown-menu dropdown-menu-right">
							<li><a href="/durham-nc/news/" title="News">News</a></li>
							<!--<li><a href="/durham-nc/blogs/" title="Blogs and Tweets">Blogs and Tweets</a></li>-->
							<!--<li><a href="/durham-nc/photos/" title="Photos">Photos</a></li>-->
							<!--<li><a href="/durham-nc/videos/" title="Videos">Videos</a></li>-->
						</ul>
					</li>
					<li class="dropdown navbar-item"> <a class="navbar-link" href="/durham-nc/real-estate/" role="button" aria-haspopup="true" aria-expanded="false">Real Estate</a>
						<ul class="dropdown-menu dropdown-menu-right">
							<li><a href="/durham-nc/real-estate/" title="Find a New Home">Find a New Home</a></li>
							<li><a href="/durham-nc/homes-for-sale/" title="Homes for Sale">Homes for Sale</a></li>
							<li><a href="/durham-nc/yp/real-estate-agents-realtors/" title="Find an Agent">Find an Agent</a></li>
							<li><a href="http://www.mynewplace.com/apartments/durham-nc?CID=AFL-amcn-serp-city?CID=AFL-amcn-serp-city-hartford" title="Apartments for Rent" onClick="javascript: pageTracker._trackPageview('/outgoing/real-estate_page/mynewplace/find_new_apartment_tab/durham-nc');" rel="nofollow">Apartments for Rent</a></li>
							<li><a href="/durham-nc/yp/insurance/" title="Insurance">Insurance</a></li>
							<li><a href="/durham-nc/mortgages/" title="Mortgages">Mortgages</a></li>
						</ul>
					</li>
					<!--<li class="dropdown navbar-item"> <a class="navbar-link" href="/durham-nc/volunteer-organizations/" role="button" aria-haspopup="true" aria-expanded="false">Volunteering</a> -->
						<!--<ul class="dropdown-menu dropdown-menu-right"> -->
							<!--<li><a href="/durham-nc/make-a-difference/" title="Volunteer Opportunities">Volunteer Opportunities</a></li>-->
							
							<!--<li><a href="/durham-nc/add-volunteer/" title="Find Volunteers">Find Volunteers</a></li>-->
						<!--</ul> -->
					<!--</li>-->
					<li role="separator" class="divider visible-xs"><hr></li>

					<li class="b login"><a class="formsapi-login" onclick="return false" href="/login" id="ajaxMLogin">Log In</a></li>
					<li class="b register"><a class="formsapi-register" onclick="return false" href="/register">Register</a></li>
					<li class="b logout"><a class=" log-out-cookie" href="/logout" onclick="return false">Log Out</a></li>
					<li class="b my-profile"><a class="openMyprofileInApi" onclick="return false" href="/myprofile">My Profile</a></li>

					<li class="visible-xs"><a href="http://support.americantowns.com/home" target="_blank">Help</a></li>
				</ul>
			</div>
		</div>
	</nav>
</div>

<!--  <style>
.irma {font-size:13px;margin:10px auto;padding:0 0 10px 0;text-align:center;}
span.red {color:red;}
</style>

<div class="irma">
Please call before attending any upcoming community events, as it is possible that they may be postponed or canceled as a result of Covid-19.</br />
You can find CDC updates at <a href="https://www.cdc.gov/coronavirus/2019-ncov/index.html">cdc.gov/coronavirus</a>; AARP has additional resources at <a href="https://aarp.org/coronavirus">aarp.org/coronavirus</a>
</div>

 -->












			</header>

	<div class="container">		
				<ol class="row crumbs breadcrumb small">
<li class="breadcrumb-item"><a href="/reset-town/">Select a City</a></li>
<li class="breadcrumb-item"><a href="/durham-nc/">Durham, NC</a></li>
<li class="breadcrumb-item"><a href="/durham-nc/news/">News</a></li>
<li class="breadcrumb-item">Congressman Price's Statement on the Pa… </li>
</ol>				<div class="row">
			<div class="section-banner"></div>
<div class="row twoColumn">
	<div class="col-lg-8 left-rail"><div class="module detail-page">
	<div itemscope itemtype="http://schema.org/Article">

		
		<a href="/article/edit/31495818" class="d-none btn btn-primary pull-right edit-current-article checkcanedit" data-model="Article" data-id="31495818" onclick="return false">Edit</a>
		<h1 itemprop="name" class="detail-header">Congressman Price's Statement on the Passing of Betty McCain</h1>
		
		<div class="module">

	<a href="#" data-url="//www.americantowns.com/news/congressman-prices-statement-on-the-passing-of-betty-mccain-31495818-durham-nc.html" class="p300-fb-share btn btn-facebook" data-ev-name="share" data-ev-val="facebook" data-ev-loc="article-bottom"><i class="fa fa-facebook-official"></i> <span>Share</span></a>

	<a href="#" data-url="//www.americantowns.com/news/congressman-prices-statement-on-the-passing-of-betty-mccain-31495818-durham-nc.html" data-text="News Details" data-hashtags-param="" class="p300-twitter-share btn btn-twitter" data-ev-name="share" data-ev-val="twitter" data-ev-loc="article-bottom"><i class="fa fa-twitter"></i></a>

	<a class="btn btn-pinterest fa fa-pinterest" data-pin-do="buttonPin" data-pin-custom="true" href="//www.pinterest.com/pin/create/button/?url=//www.americantowns.com/news/congressman-prices-statement-on-the-passing-of-betty-mccain-31495818-durham-nc.html&amp;media=&amp;description=Congressman Price's Statement on the Passing of Betty McCain"></a>

	<div class="btn fb-like" data-href="//www.americantowns.com/news/congressman-prices-statement-on-the-passing-of-betty-mccain-31495818-durham-nc.html" data-layout="button_count" data-action="like" data-show-faces="true" data-share="false"></div>
</div>


	
		<div class="clearfix">
					</div>

					<p>Government and Politics</p>
		
					<p>November 25, 2022</p>
		
		
				<hr />
		<div class="detail-description">
			<p>DURHAM, NC (November 25, 2022) &mdash;Today, Congressman David Price (NC-04), released the following statement on the passing of Betty McCain, former Chair of the North Carolina Democratic Party and former North Carolina Secretary of Cultural Resources.</p>
<p>&ldquo;I am saddened by the death of Betty McCain, my mentor and friend. Betty was an energetic and inspiring chair of the North Carolina Democratic Party who later served our state as Secretary of Cultural Resources. She was a beloved leader &mdash; charismatic, dedicated, funny, and welcoming &mdash; who lit up a room and lifted our sights and spirits. I am grateful to have known and worked with her and to have experienced the inspiration and encouragement she so generously offered.&rdquo;</p>		</div>
		
	</div>
</div>


</div>
	<div class="col-lg-4 right-rail"><div class="module">
		<div class="panel panel-default">
		<!-- Default panel contents -->

		<div class="panel-heading"><h2>COVID-19 Resources</h2></div>
		<!-- List group -->
		<div class="list-group">
			
			

<a class="list-group-item" href="https://coronavirusresourceguide.com/durham-nc" target="_blank">Coronavirus Resource Guide</a>
<a class="list-group-item" href="/durham-nc/prepping-guide/" target="_blank">Preppers Guide</a>

		</div>
	</div>

	

</div>



<div class="module-blank">
	<div class="panel panel-default">
		<!-- Default panel contents -->
		<div class="panel-heading"><span class="icon in-around-pin"></span>In and Around Durham, NC</div>
		
		<!-- List group -->
		<div class="list-group">
			<a href="/durham-nc/restaurants/" class="list-group-item"><span class="glyphicon glyphicon-cutlery" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Restaurants</a>
			<a href="/durham-nc/movie-times/" class="list-group-item"><span class="glyphicon glyphicon-facetime-video" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Movie Times</a>
			<a href="https://bestlocalcardeals.com/durham-nc/" class="list-group-item"><span class="glyphicon glyphicon-link" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Car Deals and Guide</a>
			<a href="/durham-nc/real-estate/" class="list-group-item"><span class="glyphicon glyphicon-film" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Real Estate</a>
			<a href="/durham-nc/jobs/" class="list-group-item"><span class="glyphicon glyphicon-user" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Jobs</a>
			<a href="/durham-nc/classifieds/" class="list-group-item"><span class="glyphicon glyphicon-check" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Classifieds</a>
			<a href="/durham-nc/gas-prices/" class="list-group-item"><span class="glyphicon glyphicon-fire" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Gas Prices</a>
			<a href="/durham-nc/yp/museums/" class="list-group-item"><span class="glyphicon glyphicon-briefcase" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Museums</a>
			<a href="/durham-nc/historical-markers-list/" class="list-group-item"><span class="glyphicon glyphicon-pushpin" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Historical Markers</a>
			<a href="/durham-nc/yp/coffee/" class="list-group-item"><span class="glyphicon glyphicon-sunglasses" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Coffee Spots</a>
			<a href="https://bestlocalcardeals.com/durham-nc/electric-charging-stations/" class="list-group-item"><span class="glyphicon glyphicon-link" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;EV Charging Stations</a>



			<a href="/durham-nc/yp/parks/" class="list-group-item"><span class="glyphicon glyphicon-link" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Parks</a>
			<!--<a href="/durham-nc/wifi/" class="list-group-item"><span class="glyphicon glyphicon-check" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Wifi</a>-->
		</div>
	</div>
</div>

</div>
	<div class="col-lg-8 left-rail"></div>
	<div class="col-lg-4 right-rail"></div>
</div>
<div class="section-bottom"></div>		</div>
	</div>
</div>

<footer id="footer">
	<div class="container"><br />
		<div class="row copyright">
	<div class="col-md-4">
		<h4>Need Help?</h4>
          <div><h4>      <a href="https://support.americantowns.com/hc/en-us/requests/new">Contact Us</a></h4></div>
		<div><a href="https://www.americantownsmedia.com/about-us">About Us</a></div>
                <div><a href="https://support.americantowns.com/hc/en-us/requests/new">Contact Us</a></div>
		<div><a href="http://support.americantowns.com">Frequently Asked Questions</a></div>
		<div><a href="/about/whyjoin.html">Why Join?</a></div>
		<div><a href="http://support.americantowns.com">Report Incorrect Information</a></div>


	</div>

	<div class="col-md-4">
		<h4>&copy; 2022  All rights reserved.</h4>
		<div><a href="https://www.americantownsmedia.com/terms">Terms and Conditions of Use</a></div>
		<div><a href="https://www.americantownsmedia.com/privacy-policy">Privacy Policy</a></div>
		<div><a href="https://www.americantownsmedia.com/dmca-policy">DMCA Policy</a></div>

	</div>

	<div class="col-md-4">
<br />
<img src="https://imgcdn-americantownscom.netdna-ssl.com/img/uploads/banner-images/ATMEDIA_MainLogo-1.png" height="88" width="212"><br /> 
<strong>&copy; 2022</strong>
Local Content Optimization powered by<br>AmericanTowns Media.

	</div>

</div>

	</div>
</footer>

<div class="modal fade modal-fullscreen" id="forms-modal" tabindex="-1" role="dialog" aria-labelledby="formsModalLabel"
	aria-hidden="true">
	<div class="modal-dialog" role="document">
		<div class="modal-content">
			<div class="modal-body my-5">
				<button type="button" class="close" data-dismiss="modal" aria-label="Close">
					<span aria-hidden="true">&times;</span>
				</button>
				<iframe onload="resizeIframe(this)" src="" ></iframe>
			</div>
			<div class="modal-footer">
			© 2022 AmericanTowns Media
			</div>
		</div>
	</div>
</div>
<style>
#forms-modal .close {
	color: #1c617b;
    opacity: 1;
    font-size: 40px;
    margin-right: 10px;
}
#forms-modal {
	padding: 0 !important;
}

#forms-modal .modal-dialog {
	height: 90%;
}

#forms-modal .modal-content {
	border: 0 none;
	border-radius: 0;
}
#forms-modal iframe {
	width:100%;
	border: none;
    min-height: calc(100vh - 200px);
}
#forms-modal .modal-footer {
	text-align: center !important;
}
</style>
<script async src="https://code.jquery.com/ui/1.12.1/jquery-ui.min.js" integrity="sha256-VazP97ZCwtekAsvgPBSUwPFKdrwD3unUfSGVYrahUqU=" crossorigin="anonymous"></script>
<script async src="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js"></script>
<script async src="https://maps.googleapis.com/maps/api/js?key=AIzaSyB7c0aYAl7_lT--ouR64Fx1lFOHVM4vMbQ"></script>
<script async src="https://p300live-americantownscom.netdna-ssl.com/js/script.min.js?v=1.09a"></script>
<script async src="https://p300live-americantownscom.netdna-ssl.com/js/americantowns.min.js?v=1.09a"></script>
<script async src="https://p300live-americantownscom.netdna-ssl.com/js/modernizr.js"></script>
<!-- Teads JS -->
<script type="text/javascript" class="teads" src="//a.teads.tv/page/142998/tag" async="true"></script>

<!-- Avantlink JS -->
<script type="text/javascript" src="http://classic.avantlink.com/affiliate_app_confirm.php?mode=js&authResponse=dda621e3b2494aa47e90ee11bfaa98bb0e9df68b"></script>

<!-- Exit Popup from Media.net -->
<script type="text/javascript">
    window._mNHandle = window._mNHandle || {};
    window._mNHandle.queue = window._mNHandle.queue || [];
    medianet_versionId = "3161199"; 
    (function() {    
        var sct = document.createElement("script"),
        winObj = window.top || window,
        sctHl = winObj.document.getElementsByTagName("script")[0];
        sct.type = "text/javascript";
        sct.src = '//contextual.media.net/einslmedianet.js?cid=8CU8L15W1&crid=574467807&size=641x481';
        sct.async = "async";
        sctHl.parentNode.insertBefore(sct, sctHl);
    })();
</script>

<!-- Google Code for Remarketing tag -->
<!-- Remarketing tags may not be associated with personally identifiable information or placed on pages related to sensitive categories. For instructions on adding this tag and more information on the above requirements, read the setup guide: google.com/ads/remarketingsetup -->
<script type="text/javascript">
/* <![CDATA[ */
var google_conversion_id = 1070971030;
var google_conversion_label = "rHCLCNjt9AMQlvHW_gM";
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]> */
</script>
<script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
</script>
<noscript>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/1070971030/?value=0&amp;label=rHCLCNjt9AMQlvHW_gM&amp;guid=ON&amp;script=0"/>
</div>
</noscript>

<script type="text/javascript">
    var po_host=(("https:"==document.location.protocol)?"https://":"http://");
    document.write(unescape("%3Cscript src='"+po_host+"embed.homeyou.com/americantowns.js?key=b7863d58c5aaf4135ad37fbae34ab588ded34cb1&buttons=&keyword=congressman-prices-statement-on-the-passing-of-betty-mccain-31495818-durham-nc.html' type='text/javascript'%3E%3C/script%3E"));
</script>

</body>
</html>