<!DOCTYPE html>
<html lang="en">
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />    <meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1">
    <link href="/favicon.ico" type="image/x-icon" rel="icon"/><link href="/favicon.ico" type="image/x-icon" rel="shortcut icon"/>	<title>UScellular Announces $64.3 Million Network Investment in North Carolina in 2020 - Asheville, NC</title>
	<meta name="page_title" content="UScellular Announces $64.3 Million Network Investment in North Carolina in 2020 - Asheville, NC"/>
	<meta name="robots" content="index, follow"/>
	<meta content="UScellular Announces $64.3 Million Network Investment in North Carolina in 2020 - Asheville, NC" name="description"/>
	<meta content="UScellular, Announces, 64, 3, Million, Network, Investment, in, North, Carolina, 2020, Asheville, NC" name="keywords"/>
	<link rel="canonical" href="https://www.americantowns.com/news/uscellular-announces-643-million-network-investment-in-north-carolina-in-2020-31051441-asheville-nc.html" />
	<meta name="twitter:card" content="name"/>
	<meta property="og:url" content="http://www.americantowns.com/news/uscellular-announces-643-million-network-investment-in-north-carolina-in-2020-31051441-asheville-nc.html"/>
	<link href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/css/bootstrap.min.css" rel="stylesheet">
	<link href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/css/bootstrap-theme.min.css">

	<link rel="shortcut icon" href=""/>
	<link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.4.0/css/font-awesome.min.css" rel="stylesheet">
	<link href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,400,300,600,700' rel='stylesheet' type='text/css'>
	<link rel="stylesheet" href="https://p300live-americantownscom.netdna-ssl.com/css/animate.min.css">
	<link rel="stylesheet" href="https://p300live-americantownscom.netdna-ssl.com/css/style.min.css?v=1.6">
	<link rel="stylesheet" href="https://p300live-americantownscom.netdna-ssl.com/css/americantowns.min.css?v=1.6">
		<style type="text/css">
	.adname {font-size:10px; text-align:center;}

	</style>
		<!--token : Header Script Module-->
	<!-- jQuery (necessary for Bootstrap's JavaScript plugins) -->
	<!--script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.4/jquery.min.js"></script-->
	<script
  src="https://code.jquery.com/jquery-3.2.1.min.js"
  integrity="sha256-hwg4gsxgFZhOsEEamdOYGBf13FyQuiTwlAQgxVSNgt4="
  crossorigin="anonymous"></script>
	<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '1662663580647713');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1662663580647713&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-370662-1', 'americantowns.com');
  ga('send', 'pageview');
var dimensionValue = '1';
ga('set', 'dimension1', 'Asheville, NC');
</script>


<!-- START OF Onclick Google Analytics TAG -->
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-45868632-1']);
  _gaq.push(['_trackPageview']);
 _gaq.push(['_trackPageLoadTime']);
ga('1', 'Asheville, NC', 'Town');
  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();


function _pageTracker (type) {
this.type = type;
this._trackEvent = function(a,b,c) {
_gaq.push(['_trackEvent', a, b, c]);
};
this._trackPageview = function(a) {
_gaq.push(['_trackPageview', a]);
};
}
var pageTracker = new _pageTracker();

</script>
<!-- END OF Onclick Google Analytics Tag -->

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>


<script type="text/javascript">
 var p = /yp\/.*escort/g;
 var Restricted = p.test(window.location.href);
</script>

<script type='text/javascript'>
if (!Restricted) {
googletag.cmd.push(function() {
googletag.defineSlot('/1005417/AmericanTowns_728_Top_Interior', [728, 90], 'div-gpt-ad-1365456931459-2').addService(googletag.pubads());
googletag.defineSlot('/1005417/AmericanTowns_728_Top_Interior_Left', [728, 90], 'div-gpt-ad-1367007795783-0').addService(googletag.pubads());
googletag.defineSlot('/1005417/AmericanTowns_300_Top_Side', [300, 250], 'div-gpt-ad-1365456931459-0').addService(googletag.pubads());
googletag.defineSlot('/1005417/AmericanTowns_728_Bottom_Interior', [728, 90], 'div-gpt-ad-1365456931459-1').addService(googletag.pubads());

googletag.pubads().setTargeting('State', 'NC');
googletag.pubads().setTargeting('County', 'Buncombe County');
googletag.pubads().setTargeting('City', 'Asheville');

googletag.enableServices();
});
}
</script>
<script language="JavaScript">
/*GA_googleAddAttr("State", "NC");
GA_googleAddAttr("County", "Buncombe County");
GA_googleAddAttr("City", "Asheville");*/
</script>

    <script>
		var basecdn = 'https://p300live-americantownscom.netdna-ssl.com';
			</script>
	<script type="text/javascript" async src="//forms.americantowns.com/js/formsApi.js"></script> 
	<script type="text/javascript" async src="//forms.americantowns.com/js/jspopupscript.js"></script>  
	<link rel="stylesheet" href="//forms.americantowns.com/css/jspopupstyle.css">
	</head>
<body>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=136197816738139";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<div id="wrapper" class="single-page">
	<header id="header" data-domain="forms.americantowns.com">
		<!--token : Header Menu Module-->
		<script type="text/javascript">
 window._taboola = window._taboola || [];
_taboola.push({article:'auto'}); 
!function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
}(document.createElement('script'), document.getElementsByTagName('script')[0], 'https://cdn.taboola.com/libtrc/americantownsllc-americantowns/loader.js');
</script>



  <!--
  ~ Copyright (C) 2014-2015 Media.net Advertising FZ-LLC All Rights Reserved
  -->
<script type="text/javascript">
    window._mNHandle = window._mNHandle || {};
    window._mNHandle.queue = window._mNHandle.queue || [];
    medianet_versionId = "3161199"; 
    (function() {    
        var sct = document.createElement("script"),
        winObj = window.top || window,
        sctHl = winObj.document.getElementsByTagName("script")[0];
        sct.type = "text/javascript";
        sct.src = '//contextual.media.net/einslmedianet.js?cid=8CU8L15W1&crid=574467807&size=641x481';
        sct.async = "async";
        sctHl.parentNode.insertBefore(sct, sctHl);
    })();
</script>

   <!--
  ~ Copyright (C) 2014-2015 Media.net Advertising FZ-LLC All Rights Reserved
  -->
<script type="text/javascript">
    window._mNHandle = window._mNHandle || {};
    window._mNHandle.queue = window._mNHandle.queue || [];
    medianet_versionId = "3111199"; 
    (function() {    
        var sct = document.createElement("script"),
        winObj = window.top || window,
        sctHl = winObj.document.getElementsByTagName("script")[0];
        sct.type = "text/javascript";
        sct.src = '//contextual.media.net/nmedianet.js?cid=8CU8L15W1&crid=484528839&size=316x150';
        sct.async = "async";
        sctHl.parentNode.insertBefore(sct, sctHl);
    })();
</script>

<script type="text/javascript">
    window._mNHandle = window._mNHandle || {};
    window._mNHandle.queue = window._mNHandle.queue || [];
    medianet_versionId = "3121199"; 
</script>
<script src="//contextual.media.net/dmedianet.js?cid=8CU8L15W1" async="async"></script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-2972288465131749",
          enable_page_level_ads: true
     });
</script>


<div class="container header-banner">
<div class="col-sm-6 location">
<div class="media">
<div class="media-left media-middle atn-logo ">
<a href="/reset-town/"><img class="media-object" src="//imgcdn-americantownscom.netdna-ssl.com/img/at-logo.png" alt="american towns"></a>
</div>
<div class="media-body">
<h1 class="media-heading"><a href="/asheville-nc/">Asheville</a></h1>
<h3>North Carolina <button type="button" class="btn btn-primary btn-xs" data-toggle="modal" data-target="#chgn-city">Nearby Towns</button></h3>
<div class="modal fade chgn-city" id="chgn-city" tabindex="-1" role="dialog" aria-labelledby="basicModal" aria-hidden="true">
	<div class="modal-dialog">
		<div class="modal-content">
			<div class="modal-header" id="changecityheader">
				<button type="button" class="modalCloseImg close" data-dismiss="modal" aria-hidden="true">X</button>
				<div class="modal-title">See Nearby Cities</div>
			</div>
			<div class="modal-body">
				<div id="changecity">
					<div id="city-list" data-count="0">
											<div class="row">
							<div class="col-sm-5">
								<ul>
																	<li><a href="/asheville-nc/">Asheville</a></li>
																	<li><a href="/enka-nc/">Enka</a></li>
																	<li><a href="/skyland-nc/">Skyland</a></li>
																	<li><a href="/weaverville-nc/">Weaverville</a></li>
																	<li><a href="/arden-nc/">Arden</a></li>
																	<li><a href="/candler-nc/">Candler</a></li>
																	<li><a href="/swannanoa-nc/">Swannanoa</a></li>
																	<li><a href="/alexander-nc/">Alexander</a></li>
																	<li><a href="/fairview-nc/">Fairview</a></li>
																</ul>
							</div>
							<div class="col-sm-7">
								<ul>
																	<li><a href="/leicester-nc/">Leicester</a></li>
																	<li><a href="/fletcher-nc/">Fletcher</a></li>
																	<li><a href="/black-mountain-nc/">Black Mountain</a></li>
																	<li><a href="/naples-nc/">Naples</a></li>
																	<li><a href="/gerton-nc/">Gerton</a></li>
																	<li><a href="/mountain-home-nc/">Mountain Home</a></li>
																
									<li><a href="/nc/">All North Carolina Cities</a></li>
									<li><a href="/reset-town/">Explore Another City</a></li>
								</ul>
							</div>
						</div>
										</div>						
					
				</div>
			</div>
			<div class="modal-footer">
				 <div id="city-list-search">
					<form id="form1" action="#" class="form-inline" method="get" name="form1">
						<div><label for="choose_city">Don't see the city you're looking for?</label></div>
						<input value="true" name="setts" type="hidden">
						<div class="form-group">
							<input id="choose_city" name="search_terms" class="form-control city-state" placeholder="City and State, or ZIP Code" type="text">
						</div>
						<button id="changecitybutton" type="button" class="submit btn btn-primary" alt="Submit button">Search</button>
						<button type="button" class="go-to-browser-location btn btn-primary" alt="Submit button" title="Use Browser/Current Location"><i class="fa fa-location-arrow"></i></button>
					</form>
				</div>	
			</div>
		</div>
	</div>
</div>



</div>
</div>
</div>
<div class="col-sm-6 hidden-xs">
<div class="login">
<div class="americantowns-full-logo sprite hide-text"><a href="/reset-town/">AmericanTowns.com</a></div>
<ul id="user-nav" class="list-inline text-right">
<li class="b login"><a class="formsapi-login" onclick="return false" href="/login" id="ajaxMLogin">Log In</a></li>
<li class="b register"><a class="formsapi-register" onclick="return false" href="/register">Register</a></li>
<li class="b logout"><a class=" log-out-cookie" href="/logout" onclick="return false">Log Out</a></li>
<li class="b my-profile"><a class="openMyprofileInApi" onclick="return false" href="/myprofile">My Profile</a></li>
<li><a href="http://support.americantowns.com/home" target="_blank">Help</a></li>
<li><a class="rss-link sprite icon" href="/asheville-nc/rss"><span class="hidden">Subscribe to our RSS</span></a></li>
<li><a target="_blank" class="twitter-link sprite icon" href="https://twitter.com/AmericanTowns"><span class="hidden">Follow us on twitter</span></a></li>
<li><a target="_blank" class="facebook-link sprite icon" href="https://www.facebook.com/bestofamericantowns/"><span class="hidden">Follow us on Facebook</span></a></li>
<li class="no-pad"><a target="_blank" class="mail-link sprite" href="http://support.americantowns.com/anonymous_requests/new">Email us</a></li>
</ul>	
</div>

</div>
</div>
<div class="header-menu autoresize">
	<nav class="atn navbar navbar-default">
		<div class="container container-fluid"> 
			<!-- Brand and toggle get grouped for better mobile display -->
			<div class="navbar-header">
				<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1" aria-expanded="false"> <span class="sr-only">Toggle navigation</span> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </button>
				<a class="navbar-brand" href="#">MENU</a>
			</div>

			<!-- Collect the nav links, forms, and other content for toggling -->
			<div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1">
				<ul class="nav navbar-nav">
					<li class="dropdown navbar-item"><a class="navbar-link home" href="/asheville-nc/" title="Home"><i class="glyphicon glyphicon-home"></i></a></li>

<li class="dropdown navbar-item"> <a class="navbar-link" role="button" aria-haspopup="true" aria-expanded="false">Local Guides</a>
						<ul class="dropdown-menu">

<li><a href="https://todayslocaldeals.com/asheville-nc/" title="Deals & Coupons">Deals & Coupons</a></li>		
<li><a href="https://communityanswerbook.com/asheville-nc/" title="Community Answer Book">Community Answer Book</a></li>			
<li><a href="https://coronavirusresourceguide.com/asheville-nc/" title="Coronavirus Resource Guide">Coronavirus Resource Guide</a></li>							
<li><a href="/asheville-nc/prepping-guide/" title="Prepper's Guide">Prepper's Guide</a></li>
							
													</ul>
					</li>

					<li class="dropdown navbar-item"><a class="navbar-link" href="/asheville-nc/things-to-do/" role="button" aria-haspopup="true" aria-expanded="false">Entertainment</a>
						<ul class="dropdown-menu">
							<li><a href="/asheville-nc/things-to-do/" title="Things To Do">Things To Do</a></li>
                                                        <li><a href="/asheville-nc/local-food/" title="Farmers' Markets">Farmers' Markets</a></li>
                                                        <li><a href="/asheville-nc/movie-times/" title="Movie Times">Movie Times</a></li>
							<li><a href="/asheville-nc/events-this-weekend/" title="Events this Weekend">Events this Weekend</a></li>
							<li><a href="/asheville-nc/events/" title="All Events">All Events</a></li>
                                                        <li><a href="/asheville-nc/4th-of-july-2019-fireworks-parades/" title="July 4th Fireworks">July 4th Fireworks</a></li>
                                                        <li><a href="/asheville-nc/apple-picking-and-apple-farms/" title="Apple Picking">Apple Picking</a></li>
                                                        <li><a href="/asheville-nc/corn-mazes/" title="Corn Mazes">Corn Mazes</a></li>
                                                        <li><a href="/asheville-nc/pumpkin-patch-farms-and-pumpkin-picking" title="Pumpkin Picking">Pumpkin Picking</a></li>
                                                        <li><a href="/asheville-nc/trick-or-treat-halloween-events-haunted-houses/" title="Halloween events">Halloween Events</a></li>
                                                        <li><a href="/asheville-nc/ice-skating-rinks/" title="Ice Skating Rinks">Ice Skating Rinks</a></li>
                                                        <li><a href="/asheville-nc/ski-resorts/" title="Ski Resorts & Mountains">Ski & Snowboard Resorts</a></li>
                                                        <li><a href="/asheville-nc/cut-your-own-christmas-tree/" title="Christmas Tree Farms">Christmas Tree Farms</a></li>
						</ul>
					</li>
					<li class="dropdown navbar-item"> <a class="navbar-link" href="/asheville-nc/restaurants/" role="button" aria-haspopup="true" aria-expanded="false">Restaurants</a>
						<ul class="dropdown-menu">
							<li><a href="/asheville-nc/restaurants/" title="Restaurants">Restaurants</a></li>
							<!--<li><a href="/asheville-nc/restaurant-coupons/" title="Restaurant Coupons">Restaurant Coupons</a></li>-->
													</ul>
					</li>
					<li class="dropdown navbar-item"> <a class="navbar-link" href="/asheville-nc/businesses/" role="button" aria-haspopup="true" aria-expanded="false">Directory</a>
						<ul class="dropdown-menu">
							<li><a href="/asheville-nc/businesses/" title="Directory">Directory</a></li>
							<li><a href="/asheville-nc/yp/accountants/" title="Accountants">Accountants</a></li>
							<li><a href="/asheville-nc/yp/physicians-and-surgeons/" title="Doctors">Doctors</a></li>
							<li><a href="/asheville-nc/yp/dentists/" title="Dentists">Dentists</a></li>
							<li><a href="/asheville-nc/yp/florists/" title="Florists">Florists</a></li>
							<li><a href="/asheville-nc/yp/moving-storage/" title="Moving / Storage">Moving / Storage</a></li>
							<li><a href="/asheville-nc/yp/plumbers/" title="Plumbers">Plumbers</a></li>
							<li><a href="/asheville-nc/directory/" title="White Pages">White Pages</a></li>
							<li><a href="/asheville-nc/zip-code/" title="Zip Codes">Zip Codes</a></li>
							<li><a href="/asheville-nc/tv-stations/" title="TV Stations">TV Stations</a></li>
						</ul>
					</li>
					<!-- <li class="dropdown navbar-item"> <a class="navbar-link" href="/asheville-nc/maps/" role="button" aria-haspopup="true" aria-expanded="false">Travel &amp; Transit</a>
						<!-- <ul class="dropdown-menu"> -->
							<!--<li><a href="/asheville-nc/travel-transit/" title="Travel &amp; Transit">Travel &amp; Transit</a></li>-->
							<!--<li><a href="/asheville-nc/travel-transit/" title="Car Rental">Car Rental</a></li>-->
							<!--<li><a href="/asheville-nc/travel-transit/" title="Flights">Flights</a></li>-->
							<!--<li><a href="/asheville-nc/travel-transit/" title="Hotels">Hotels</a></li>-->
							
							
							<!--<li><a href="/asheville-nc/weather/" title="Weather">Weather</a></li>-->
							<!--<li><a href="/asheville-nc/wifi/" title="WiFi">WiFi</a></li>-->
						<!-- </ul> -->
					<!-- </li> -->
					<li class="dropdown navbar-item"> <a class="navbar-link" href="/asheville-nc/info/" role="button" aria-haspopup="true" aria-expanded="false">Community Life</a>
						<ul class="dropdown-menu">

<li><a href="https://coronavirusresourceguide.com/asheville-nc/" title="Coronavirus Resource Guide">Coronavirus Resource Guide</a></li>							
<li><a href="/asheville-nc/prepping-guide/" title="Prepper's Guide">Prepper's Guide</a></li>
							
<li><a href="/asheville-nc/events/" title="Events Calendar">Events Calendar</a></li>
							<li><a href="/asheville-nc/info/" title="Government">Community Profile</a></li>
							<li><a href="/asheville-nc/organizations/government-and-politics/" title="Government">Government</a></li>
							<li><a href="/asheville-nc/organizations/religion-and-spirituality/" title="Houses of Worship">Houses of Worship</a></li>
							<li><a href="/asheville-nc/organizations/clubs-and-organizations/" title="Clubs and Non-Profits">Clubs and Non-Profits</a></li>
                                                        <li><a href="/asheville-nc/volunteer-organizations/" title="Volunteer Organizations">Volunteer Organizations</a></li>
							<li><a href="/asheville-nc/school-closings/" title="School Delays and Closings">School Delays and Closings</a></li>
							<li><a href="/asheville-nc/organizations/schools-and-libraries/" title="Schools, Libraries">Schools, Libraries</a></li>
							<li><a href="/asheville-nc/obituaries/" title="Obituaries">Obituaries</a></li>
							<li><a href="/asheville-nc/organizations/" title="All Organizations">All Organizations</a></li> 
                                                        <li><a href="/asheville-nc/maps/" title="Maps">Maps</a></li>
                                                        <li><a href="/asheville-nc/gas-prices/" title="Gas Prices">Gas Prices</a></li>
                                                        <li><a href="/asheville-nc/traffic-trains/" title="Traffic / Trains">Traffic / Trains</a></li>

						</ul>
					</li>
					<li class="dropdown navbar-item"> <a class="navbar-link" href="/asheville-nc/classifieds/" role="button" aria-haspopup="true" aria-expanded="false">Classifieds / Jobs</a>
						<ul class="dropdown-menu">
							<li><a href="/asheville-nc/classifieds/" title="Classifieds">Classifieds</a></li>
							<li><a href="/asheville-nc/jobs/" title="Jobs">Jobs</a></li>
							<!--<li><a href="/asheville-nc/coupons/" title="Coupons">Coupons</a></li>-->
							<!--<li><a href="/asheville-nc/restaurant-coupons/" title="Restaurant Coupons">Restaurant Coupons</a></li>-->
						</ul>
					</li>
					<li class="dropdown navbar-item"> <a class="navbar-link" href="/asheville-nc/news/" role="button" aria-haspopup="true" aria-expanded="false">News</a>
						<ul class="dropdown-menu dropdown-menu-right">
							<li><a href="/asheville-nc/news/" title="News">News</a></li>
							<!--<li><a href="/asheville-nc/blogs/" title="Blogs and Tweets">Blogs and Tweets</a></li>-->
							<!--<li><a href="/asheville-nc/photos/" title="Photos">Photos</a></li>-->
							<!--<li><a href="/asheville-nc/videos/" title="Videos">Videos</a></li>-->
						</ul>
					</li>
					<li class="dropdown navbar-item"> <a class="navbar-link" href="/asheville-nc/real-estate/" role="button" aria-haspopup="true" aria-expanded="false">Real Estate</a>
						<ul class="dropdown-menu dropdown-menu-right">
							<li><a href="/asheville-nc/real-estate/" title="Find a New Home">Find a New Home</a></li>
							<li><a href="/asheville-nc/homes-for-sale/" title="Homes for Sale">Homes for Sale</a></li>
							<li><a href="/asheville-nc/yp/real-estate-agents-realtors/" title="Find an Agent">Find an Agent</a></li>
							<li><a href="http://www.mynewplace.com/apartments/asheville-nc?CID=AFL-amcn-serp-city?CID=AFL-amcn-serp-city-hartford" title="Apartments for Rent" onClick="javascript: pageTracker._trackPageview('/outgoing/real-estate_page/mynewplace/find_new_apartment_tab/asheville-nc');" rel="nofollow">Apartments for Rent</a></li>
							<li><a href="/asheville-nc/yp/insurance/" title="Insurance">Insurance</a></li>
							<li><a href="/asheville-nc/mortgages/" title="Mortgages">Mortgages</a></li>
						</ul>
					</li>
					<!--<li class="dropdown navbar-item"> <a class="navbar-link" href="/asheville-nc/volunteer-organizations/" role="button" aria-haspopup="true" aria-expanded="false">Volunteering</a> -->
						<!--<ul class="dropdown-menu dropdown-menu-right"> -->
							<!--<li><a href="/asheville-nc/make-a-difference/" title="Volunteer Opportunities">Volunteer Opportunities</a></li>-->
							
							<!--<li><a href="/asheville-nc/add-volunteer/" title="Find Volunteers">Find Volunteers</a></li>-->
						<!--</ul> -->
					<!--</li>-->
					<li role="separator" class="divider visible-xs"><hr></li>

					<li class="b login"><a class="formsapi-login" onclick="return false" href="/login" id="ajaxMLogin">Log In</a></li>
					<li class="b register"><a class="formsapi-register" onclick="return false" href="/register">Register</a></li>
					<li class="b logout"><a class=" log-out-cookie" href="/logout" onclick="return false">Log Out</a></li>
					<li class="b my-profile"><a class="openMyprofileInApi" onclick="return false" href="/myprofile">My Profile</a></li>

					<li class="visible-xs"><a href="http://support.americantowns.com/home" target="_blank">Help</a></li>
				</ul>
			</div>
		</div>
	</nav>
</div>

<style>
.irma {font-size:14px;margin:10px auto;width:85%;padding:0 0 10px 0;}
span.red {color:red;}
</style>

<div class="irma">
<span class="red">Please call before attending any community events. </span> It is likely that they will be <b>postponed or canceled</b> as a result of the coronavirus. You can find CDC coronavirus information at <a href="https://www.cdc.gov/coronavirus/2019-ncov/index.html">cdc.gov/coronavirus</a>; AARP has additional resources at <a href="https://aarp.org/coronavirus">aarp.org/coronavirus</a>
</div>














			</header>

	<div class="container">		
				<ol class="row crumbs breadcrumb small">
<li class="breadcrumb-item"><a href="/reset-town/">Select a City</a></li>
<li class="breadcrumb-item"><a href="/asheville-nc/">Asheville, NC</a></li>
<li class="breadcrumb-item"><a href="/asheville-nc/news/">News</a></li>
<li class="breadcrumb-item">UScellular Announces $64.3 Million Network Investment in North Carolina in 2020 </li>
</ol>				<div class="row">
			<div></div>
<div class="row twoColumn">
	<div class="col-md-8 left-rail"><div class="module detail-page">
	<div itemscope itemtype="http://schema.org/Article">

		
		<a href="/article/edit/31051441" class="hidden btn btn-primary pull-right edit-current-article checkcanedit" data-model="Article" data-id="31051441" onclick="return false">Edit</a>
		<h1 itemprop="name" class="detail-header">UScellular Announces $64.3 Million Network Investment in North Carolina in 2020</h1>
		
		<div class="module">

	<a href="#" data-url="//www.americantowns.com/news/uscellular-announces-643-million-network-investment-in-north-carolina-in-2020-31051441-asheville-nc.html" class="p300-fb-share btn btn-facebook" data-ev-name="share" data-ev-val="facebook" data-ev-loc="article-bottom"><i class="fa fa-facebook-official"></i> <span>Share</span></a>

	<a href="#" data-url="//www.americantowns.com/news/uscellular-announces-643-million-network-investment-in-north-carolina-in-2020-31051441-asheville-nc.html" data-text="News Details" data-hashtags-param="" class="p300-twitter-share btn btn-twitter" data-ev-name="share" data-ev-val="twitter" data-ev-loc="article-bottom"><i class="fa fa-twitter"></i></a>

	<a class="btn btn-pinterest fa fa-pinterest" data-pin-do="buttonPin" data-pin-custom="true" href="//www.pinterest.com/pin/create/button/?url=//www.americantowns.com/news/uscellular-announces-643-million-network-investment-in-north-carolina-in-2020-31051441-asheville-nc.html&amp;media=&amp;description=UScellular Announces $64.3 Million Network Investment in North Carolina in 2020"></a>

	<div class="btn fb-like" data-href="//www.americantowns.com/news/uscellular-announces-643-million-network-investment-in-north-carolina-in-2020-31051441-asheville-nc.html" data-layout="button_count" data-action="like" data-show-faces="true" data-share="false"></div>
</div>


	
		<div class="clearfix">
					</div>

					<p>Business and Professional</p>
		
					<p>February 18, 2021</p>
		
		
				<hr />
		<div class="detail-description">
			<p dir="ltr" style="line-height: 1.2; margin-top: 0pt; margin-bottom: 0pt;"><span style="font-size: 10pt; font-family: Arial; color: #000000; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: none; vertical-align: baseline; white-space: pre-wrap;">UScellular announced today that it made a $64.3 million investment in its North Carolina network in 2020, including $28.3 million in 5G upgrades that bring customers faster data speeds, a more responsive mobile experience and the ability to connect more devices to the network at the same time.&nbsp;</span></p>
<p><b style="font-weight: normal;">&nbsp;</b></p>
<p dir="ltr" style="line-height: 1.2; margin-top: 0pt; margin-bottom: 0pt;"><span style="font-size: 10pt; font-family: Arial; color: #000000; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: none; vertical-align: baseline; white-space: pre-wrap;">&ldquo;We take the responsibility of keeping our customers connected very seriously, and every investment we make in our network is designed to enhance their wireless experience,&rdquo; said Nathan Waddell, director of sales for UScellular in western North Carolina. &ldquo;Last year showed us that wireless service has never been more essential, so we are dedicated to bringing the latest technology to more of our customers to ensure they can stay connected to the people and information they need.&rdquo;</span></p>
<p><b style="font-weight: normal;">&nbsp;</b></p>
<p dir="ltr" style="line-height: 1.2; margin-top: 0pt; margin-bottom: 0pt;"><span style="font-size: 10pt; font-family: Arial; color: #000000; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: none; vertical-align: baseline; white-space: pre-wrap;">Additionally, as UScellular continues to build out its 5G device portfolio, it invested $1.4 million in its North Carolina retail store environments in 2020 to create a better shopping experience and showcase the variety of smartphones, tablets, hotspots and wireless tech accessories available for customers. This includes 20 redesigned or upgraded stores across the state throughout the year including one here in Buncombe County located at 7 North Ridge Commons Parkway in Weaverville.&nbsp;</span></p>
<p><b style="font-weight: normal;">&nbsp;</b></p>
<p dir="ltr" style="line-height: 1.2; margin-top: 0pt; margin-bottom: 0pt;"><span style="font-size: 10pt; font-family: Arial; color: #000000; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: none; vertical-align: baseline; white-space: pre-wrap;">For the sixth year in a row, UScellular donated $1 million to Boys &amp; Girls of America to support youth in its communities, $86,000 of which went directly to five clubs in North Carolina. For more information about UScellular&rsquo;s network coverage, retail locations and corporate social responsibility, please go to </span><a href="https://www.uscellular.com/" style="text-decoration: none;"><span style="font-size: 10pt; font-family: Arial; color: #0000ff; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: underline; vertical-align: baseline; white-space: pre-wrap;">uscellular.com</span></a><span style="font-size: 10pt; font-family: Arial; color: #000000; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: none; vertical-align: baseline; white-space: pre-wrap;">.&nbsp;</span></p>
<p><b style="font-weight: normal;">&nbsp;</b></p>
<p dir="ltr" style="line-height: 1.2; margin-top: 0pt; margin-bottom: 0pt;"><span style="font-size: 10pt; font-family: Arial; color: #000000; background-color: transparent; font-weight: bold; font-style: normal; font-variant: normal; text-decoration: none; vertical-align: baseline; white-space: pre-wrap;">About UScellular</span></p>
<p></p>
<p dir="ltr" style="line-height: 1.2; margin-top: 0pt; margin-bottom: 0pt;"><span style="font-size: 10pt; font-family: Arial; color: #000000; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: none; vertical-align: baseline; white-space: pre-wrap;">UScellular is the fourth-largest full-service wireless carrier in the United States, providing national network coverage and industry-leading innovations designed to elevate the customer experience. The Chicago-based carrier is building a stronger network with the latest&nbsp;</span><a href="https://www.youtube.com/watch?v=LB9naOCxSFI&amp;feature=youtu.be" style="text-decoration: none;"><span style="font-size: 10pt; font-family: Arial; color: #0000ff; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: underline; vertical-align: baseline; white-space: pre-wrap;">5G technology</span></a><span style="font-size: 10pt; font-family: Arial; color: #000000; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: none; vertical-align: baseline; white-space: pre-wrap;">&nbsp;and offers a wide range of communication services that enhance consumers&rsquo; lives, increase the competitiveness of local businesses and improve the efficiency of government operations. To learn more about UScellular, visit one of its retail stores or&nbsp;</span><a href="http://www.uscellular.com/" style="text-decoration: none;"><span style="font-size: 10pt; font-family: Arial; color: #0000ff; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: underline; vertical-align: baseline; white-space: pre-wrap;">www.uscellular.com</span></a><span style="font-size: 10pt; font-family: Arial; color: #000000; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: none; vertical-align: baseline; white-space: pre-wrap;">. To get the latest news, promos and videos, connect with UScellular on </span><a href="https://www.facebook.com/USCellular" style="text-decoration: none;"><span style="font-size: 10pt; font-family: Arial; color: #0000ff; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: underline; vertical-align: baseline; white-space: pre-wrap;">Facebook.com/uscellular</span></a><span style="font-size: 10pt; font-family: Arial; color: #000000; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: none; vertical-align: baseline; white-space: pre-wrap;">, </span><a href="http://www.twitter.com/uscellular" style="text-decoration: none;"><span style="font-size: 10pt; font-family: Arial; color: #0000ff; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: underline; vertical-align: baseline; white-space: pre-wrap;">Twitter.com/uscellular</span></a><span style="font-size: 10pt; font-family: Arial; color: #000000; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: none; vertical-align: baseline; white-space: pre-wrap;"> and </span><a href="http://www.youtube.com/uscellularcorp" style="text-decoration: none;"><span style="font-size: 10pt; font-family: Arial; color: #0000ff; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: underline; vertical-align: baseline; white-space: pre-wrap;">YouTube.com/uscellularcorp</span></a><span style="font-size: 10pt; font-family: Arial; color: #000000; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: none; vertical-align: baseline; white-space: pre-wrap;">.</span></p>
<p><span style="font-size: 10pt; font-family: Arial; color: #000000; background-color: transparent; font-weight: 400; font-style: normal; font-variant: normal; text-decoration: none; vertical-align: baseline; white-space: pre-wrap;">&nbsp;</span></p>		</div>
		
	</div>
</div>


<!--
  ~ Copyright (C) 2014 Media.net Advertising FZ-LLC All Rights Reserved
  -->
<div id="557403633">
  	<script type="text/javascript">
	  try {
		   window._mNHandle.queue.push(function () {
		   	window._mNDetails.loadTag("557403633", "600x250", "557403633");
		  	});
		  }
	  catch (error) {}
	</script>
  </div>

<div id="ZillowHere"><div class="alert alert-warning" role="alert">Loading Zillow...</div></div>
<script type="text/javascript">
$( document ).ready(function() {
    console.log('loading zillow');
    $.ajax({
    	url: '/ajax/real_estate/form_agent_disp/limit:6/utm_source:American+Towns/utm_medium:referral/utm_campaign:P300_List/cbpartner:American+Towns/'
    }).done(function( msg ) {
    	$('#ZillowHere').html(msg);
    }).fail(function () {
        $('#ZillowHere').html('');
    });
    console.log('end zillow');
});
</script>

</div>
	<div class="col-md-4 right-rail"><div class="module">
		<div class="panel panel-default">
		<!-- Default panel contents -->

		<div class="panel-heading"><h2>COVID-19 Resources</h2></div>
		<!-- List group -->
		<div class="list-group">
			
			

<a class="list-group-item" href="https://coronavirusresourceguide.com/asheville-nc" target="_blank">Coronavirus Resource Guide</a>
<a class="list-group-item" href="/asheville-nc/prepping-guide/" target="_blank">Preppers Guide</a>

		</div>
	</div>

	

</div>



<!-- AmericanTowns_300_Top_Side -->
<div id="div-gpt-ad-1365456931459-0" class="blue-module" style="width:300px; height:250px;margin:10px auto;">
<script type="text/javascript">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1365456931459-0'); });
</script>
</div>

<div class="module-blank">
	<div class="panel panel-default">
		<!-- Default panel contents -->
		<div class="panel-heading"><span class="icon in-around-pin"></span>In and Around Asheville, NC</div>
		
		<!-- List group -->
		<div class="list-group">
			<a href="/asheville-nc/restaurants/" class="list-group-item"><span class="glyphicon glyphicon-cutlery" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Restaurants</a>
			<a href="/asheville-nc/movie-times/" class="list-group-item"><span class="glyphicon glyphicon-facetime-video" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Movie Times</a>
			<a href="/asheville-nc/real-estate/" class="list-group-item"><span class="glyphicon glyphicon-film" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Real Estate</a>
			<a href="/asheville-nc/jobs/" class="list-group-item"><span class="glyphicon glyphicon-user" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Jobs</a>
			<a href="/asheville-nc/classifieds/" class="list-group-item"><span class="glyphicon glyphicon-check" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Classifieds</a>
			<a href="/asheville-nc/gas-prices/" class="list-group-item"><span class="glyphicon glyphicon-fire" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Gas Prices</a>
			<a href="/asheville-nc/yp/museums/" class="list-group-item"><span class="glyphicon glyphicon-briefcase" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Museums</a>
			<a href="/asheville-nc/historical-markers-list/" class="list-group-item"><span class="glyphicon glyphicon-pushpin" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Historical Markers</a>
			<a href="/asheville-nc/yp/coffee/" class="list-group-item"><span class="glyphicon glyphicon-sunglasses" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Coffee Spots</a>
			<a href="/asheville-nc/yp/parks/" class="list-group-item"><span class="glyphicon glyphicon-link" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Parks</a>
			<!--<a href="/asheville-nc/wifi/" class="list-group-item"><span class="glyphicon glyphicon-check" aria-hidden="true"></span>&nbsp;&nbsp;&nbsp;Wifi</a>-->
		</div>
	</div>
</div>

</div>
	<div class="col-md-8 left-rail"></div>
	<div class="col-md-4 right-rail"></div>
</div>
		</div>
	</div>
</div>

<footer id="footer">
	<div class="container">
		<!--token : Footer Menu Module--><br />
		<div class="row copyright">
	<div class="col-md-4">
		<h4>Need Help?</h4>
          <div><h4>      <a href="https://support.americantowns.com/hc/en-us/requests/new">Contact Us</a></h4></div>
		<div><a href="https://www.americantownsmedia.com/about-us">About Us</a></div>
                <div><a href="https://support.americantowns.com/hc/en-us/requests/new">Contact Us</a></div>
		<div><a href="http://support.americantowns.com">Frequently Asked Questions</a></div>
		<div><a href="/about/whyjoin.html">Why Join?</a></div>
		<div><a href="http://support.americantowns.com">Report Incorrect Information</a></div>


	</div>

	<div class="col-md-4">
		<h4>&copy; 2019  All rights reserved.</h4>
		<div><a href="https://www.americantownsmedia.com/terms">Terms and Conditions of Use</a></div>
		<div><a href="https://www.americantownsmedia.com/privacy-policy">Privacy Policy</a></div>
		<div><a href="https://www.americantownsmedia.com/dmca-policy">DMCA Policy</a></div>

	</div>

	<div class="col-md-4">
<br />
<img src="https://imgcdn-americantownscom.netdna-ssl.com/img/uploads/banner-images/ATMEDIA_MainLogo-1.png" height="88" width="212"><br /> 
<strong>&copy; 2019</strong>
Local Content Optimization powered by<br>AmericanTowns Media.

	</div>

</div>

	</div>
</footer>


<script defer src="https://code.jquery.com/ui/1.12.1/jquery-ui.min.js" integrity="sha256-VazP97ZCwtekAsvgPBSUwPFKdrwD3unUfSGVYrahUqU=" crossorigin="anonymous"></script>
<script defer src="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js"></script>
<script defer src="https://maps.googleapis.com/maps/api/js?key=AIzaSyB7c0aYAl7_lT--ouR64Fx1lFOHVM4vMbQ"></script>
<script defer src="https://p300live-americantownscom.netdna-ssl.com/js/script.min.js?v=1.6"></script>
<script defer src="https://p300live-americantownscom.netdna-ssl.com/js/americantowns.min.js?v=1.6"></script>
<script defer src="https://p300live-americantownscom.netdna-ssl.com/js/modernizr.js"></script>
<!--
  ~ Copyright (C) 2014-2015 Media.net Advertising FZ-LLC All Rights Reserved
  -->
<script type="text/javascript">
    window._mNHandle = window._mNHandle || {};
    window._mNHandle.queue = window._mNHandle.queue || [];
    medianet_versionId = "3161199"; 
    (function() {    
        var sct = document.createElement("script"),
        winObj = window.top || window,
        sctHl = winObj.document.getElementsByTagName("script")[0];
        sct.type = "text/javascript";
        sct.src = '//contextual.media.net/einslmedianet.js?cid=8CU8L15W1&crid=574467807&size=641x481';
        sct.async = "async";
        sctHl.parentNode.insertBefore(sct, sctHl);
    })();
</script>


<!-- AddThis Smart Layers BEGIN -->
<!-- Go to https://www.addthis.com/get/smart-layers to customize -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=epanian"></script>
<script type="text/javascript">
  addthis.layers({
   'share' : {
        'position' : 'left',
        'services' : 'facebook,linkedin,twitter,google_plusone,pinterest,email,gmail',
        //'numPreferredServices' : 5,
        'postShareTitle' : 'Thanks for sharing!',
        'postShareRecommendedMsg' : 'Recommended for you',
        'desktop' : true,
        'mobile' : false,
        'theme' : 'light'
    },  
  });
</script>
<!-- AddThis Smart Layers END -->



<!-- Google Code for Remarketing tag -->
<!-- Remarketing tags may not be associated with personally identifiable information or placed on pages related to sensitive categories. For instructions on adding this tag and more information on the above requirements, read the setup guide: google.com/ads/remarketingsetup -->
<script type="text/javascript">
/* <![CDATA[ */
var google_conversion_id = 1070971030;
var google_conversion_label = "rHCLCNjt9AMQlvHW_gM";
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]> */
</script>
<script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
</script>
<noscript>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/1070971030/?value=0&amp;label=rHCLCNjt9AMQlvHW_gM&amp;guid=ON&amp;script=0"/>
</div>
</noscript>



<script>
window._taboola = window._taboola || [];
_taboola.push({article:'auto'}); 
_taboola.push({flush:true});
</script>

</body>
</html>
